المساعد الشخصي الرقمي

مشاهدة النسخة كاملة : Multi Point Route Redistribution Lab



Gawad
15-09-2011, 01:56
بسم الله والحمد لله والصلاة والسلام علي رسول الله وآله وصحبه وإخوانه وسلم

Multi Point Route Redistribution Lab


https://1.bp.blogspot.com/-0YgJ_xYCFgI/TnE7MNMxQfI/AAAAAAAAAbM/Gw84gBnkrcQ/s400/route-redis.jpg (https://1.bp.blogspot.com/-0YgJ_xYCFgI/TnE7MNMxQfI/AAAAAAAAAbM/Gw84gBnkrcQ/s1600/route-redis.jpg)

يوجد العديد من النقاط تم تغطيتها في هذا اللاب علي النحو التالي:



Lab Objectives:

1- Networks 192.168.10.0/30, 192.168.17.0 and 172.20.20.0/30 should not be advertised in OSPF domain.


R1#sho run
router ospf 100
log-adjacency-changes
redistribute rip subnets route-map RIP-TO-OSPF
!
access-list 10 permit 192.168.10.0 0.0.0.3
access-list 10 permit 192.168.17.0 0.0.0.255
access-list 10 permit 172.20.20.0 0.0.0.3
!
route-map RIP-TO-OSPF deny 10
match ip address 10
!
route-map RIP-TO-OSPF permit 20
set metric 5000
set metric-type type-2


R3# the same configuration

R5#sho ip route
Gateway of last resort is not set
C 192.168.30.0/24 is directly connected, Loopback0
172.16.0.0/30 is subnetted, 3 subnets
O 172.16.40.0 [110/129] via 172.16.30.1, 00:12:45, Serial0/0
C 172.16.30.0 is directly connected, Serial0/0
O 172.16.10.0 [110/65] via 172.16.30.1, 00:12:45, Serial0/0
O 192.168.20.0/24 [110/130] via 172.16.30.1, 00:12:45, Serial0/0
10.0.0.0/30 is subnetted, 1 subnets
O E2 10.10.10.0 [110/5000] via 172.16.30.1, 00:07:19, Serial0/0
O E2 192.168.16.0/24 [110/5000] via 172.16.30.1, 00:07:19, Serial0/0
O E2 192.168.18.0/24 [110/5000] via 172.16.30.1, 00:07:19, Serial0/0

R6#sho ip route
Gateway of last resort is not set
O 192.168.30.0/24 [110/130] via 172.16.40.1, 00:08:12, Serial0/1
172.16.0.0/30 is subnetted, 3 subnets
C 172.16.40.0 is directly connected, Serial0/1
O 172.16.30.0 [110/129] via 172.16.40.1, 00:08:12, Serial0/1
O 172.16.10.0 [110/65] via 172.16.40.1, 00:08:12, Serial0/1
C 192.168.20.0/24 is directly connected, Loopback0
10.0.0.0/30 is subnetted, 1 subnets
O E2 10.10.10.0 [110/5000] via 172.16.40.1, 00:02:46, Serial0/1
O E2 192.168.16.0/24 [110/5000] via 172.16.40.1, 00:02:46, Serial0/1
O E2 192.168.18.0/24 [110/5000] via 172.16.40.1, 00:02:46, Serial0/1

2- R3 should use RIP to reach 10.10.10.0/30, no route-maps, distribute-lists or prefix-lists should be used.

R3(config)#router ospf 100
R3(config-router)#distance ospf external 100 inter-area 100 intra-area 100
R3(config-router)#distance 100 10.10.10.0 0.0.0.3

R3(config-router)#do sho ip route
10.0.0.0/30 is subnetted, 1 subnets
R 10.10.10.0 [120/1] via 172.20.20.1, 00:00:11, Serial1/0


3- 192.168.16.0/24 should be advertised in ospf with metric of 200 and metric type of 1.

R1#sho run
!
access-list 10 permit 192.168.10.0 0.0.0.3
access-list 10 permit 192.168.17.0 0.0.0.255
access-list 10 permit 172.20.20.0 0.0.0.3
access-list 20 permit 192.168.16.0 0.0.0.255
!
route-map RIP-TO-OSPF deny 10
match ip address 10
!
route-map RIP-TO-OSPF permit 15
match ip address 20
set metric 200
set metric-type type-1
!
route-map RIP-TO-OSPF permit 20
set metric 5000
set metric-type type-2

R3# the same configuration

R3#sho ip route
O E1 192.168.16.0/24 [100/201] via 172.16.10.1, 00:04:18, FastEthernet0/0

R5#sho ip route
O E1 192.168.16.0/24 [110/264] via 172.16.30.1, 00:04:21, Serial0/0

R6#sho ip route
O E1 192.168.16.0/24 [110/265] via 172.16.40.1, 00:03:55, Serial0/1

4- Any other route redistributed in ospf should be redistributed with a metric of 5000 and type 2.
Included in question 2
5- Without redistributing ospf routes back into RIP, RIP domain routers should be able to reach any network in the ospf domain.

R1#sho run | sec rip
redistribute rip subnets route-map RIP-TO-OSPF
router rip
version 2
passive-interface FastEthernet1/0
network 192.168.10.0
default-information originate

R3#sho run | sec rip
redistribute rip subnets route-map RIP-TO-OSPF
router rip
version 2
passive-interface FastEthernet0/0
network 172.20.0.0
default-information originate
no auto-summary

R2#sho ip route
R* 0.0.0.0/0 [120/1] via 192.168.10.1, 00:00:20, FastEthernet0/0

R4#sho ip route
R* 0.0.0.0/0 [120/1] via 172.20.20.2, 00:00:25, Serial1/0



لتحميل اللاب


بسم الله (https://www.archive.org/download/route-redistribution-multi-point/route-redis-route-map.zip)

لتحميل الخطوات السابقة

بسم الله .docx (https://www.archive.org/download/route-redistribution-multi-point/route-redistribution-multi-point.docx)

بسم الله .pdf (https://www.archive.org/download/route-redistribution-multi-point/route-redistribution-multi-point.pdf)


ولا تنسوني والمسلمين من صالح الدعاء
وصلي الله وسلم وبارك علي المصطفي وآله وصحبه وإخوانه وسلم

سعيد يوسف
15-09-2011, 05:43
جزاك الله خيرا يا بشمهندس أحمد

وياريت لاب بقي يغطي ال
RIP & OSPF & EIGRP

وبذلك تكون غطيت جزئية ال
Redistribution لمنهج ال CCNP
وبارك الله في مجهودك

anduril87
15-09-2011, 08:15
2- R3 should use RIP to reach 10.10.10.0/30, no route-maps, distribute-lists or
prefix-lists should be used.
اعتقد في هنا غلطه
المفروض ان الروتر يروح للنتورك بال rip وهنا احنا قدمنا حاجتين
يا نقلل ال rip AD اقل من 110 ..او اننا نعلي ال ospf AD ونخليه اعلي من 120

R3(config-router)#do sho ip route
10.0.0.0/30 is subnetted, 1 subnets
O E2 10.10.10.0 [100/5000] via 172.16.10.1, 00:00:02, FastEthernet0/0
هنا الروتر استخدم ال ospf بعكس المطلوب في اللاب
ياريت توضيح هذه النقطه شكرا

Gawad
15-09-2011, 14:12
جزاك الله خيراً أخي الكريم
تم التعديل، تم الاقتباس بالخطأ
وصلي الله وسلم وبارك علي المصطفي وآله وصحبه وإخوانه وسلم